mirror of
https://github.com/bookorbit/bookorbit.git
synced 2026-11-03 08:21:39 -06:00
d7556011df
Update package manager configuration to pnpm 11.22.0 and Node.js requirement to Node 26 across Dockerfile, GitHub Actions workflows, root package.json, and workspace configurations. Upgrade dependencies, update GitHub Action versions, and remove deprecated scorecard workflow.
63 lines
1.8 KiB
YAML
63 lines
1.8 KiB
YAML
packages:
|
|
- "client"
|
|
- "server"
|
|
- "packages/*"
|
|
overrides:
|
|
"@xhmikosr/decompress": ^11.1.4
|
|
"@esbuild-kit/core-utils>esbuild": ^0.25.12
|
|
"@nestjs/swagger>js-yaml": ^5.3.0
|
|
"@typescript-eslint/eslint-plugin": ^8.67.0
|
|
"@typescript-eslint/parser": ^8.67.0
|
|
"@typescript-eslint/utils": ^8.67.0
|
|
"brace-expansion@>=5.0.0 <5.0.9": ^5.0.9
|
|
engine.io: ^6.6.7
|
|
esbuild: ^0.28.2
|
|
fastify: ^5.10.0
|
|
fast-uri: ^3.1.5
|
|
fast-xml-builder: ^1.3.1
|
|
find-my-way: ^9.8.0
|
|
form-data: ^4.0.6
|
|
piscina: ^4.9.3
|
|
qs: ^6.15.2
|
|
typescript-eslint: ^8.67.0
|
|
ws: ^8.21.3
|
|
packageExtensions:
|
|
"@embedpdf/utils@2.15.0":
|
|
dependencies:
|
|
"@embedpdf/models": 2.15.0
|
|
allowBuilds:
|
|
"@ffmpeg-installer/darwin-arm64": true
|
|
"@ffmpeg-installer/darwin-x64": true
|
|
"@ffmpeg-installer/linux-arm": true
|
|
"@ffmpeg-installer/linux-arm64": true
|
|
"@ffmpeg-installer/linux-ia32": true
|
|
"@ffmpeg-installer/linux-x64": true
|
|
"@ffmpeg-installer/win32-ia32": true
|
|
"@ffmpeg-installer/win32-x64": true
|
|
"@ffprobe-installer/darwin-arm64": true
|
|
"@ffprobe-installer/darwin-x64": true
|
|
"@ffprobe-installer/linux-arm": true
|
|
"@ffprobe-installer/linux-arm64": true
|
|
"@ffprobe-installer/linux-ia32": true
|
|
"@ffprobe-installer/linux-x64": true
|
|
"@ffprobe-installer/win32-ia32": true
|
|
"@ffprobe-installer/win32-x64": true
|
|
"@nestjs/core": true
|
|
"@parcel/watcher": true
|
|
"@scarf/scarf": false
|
|
"@swc/core": true
|
|
esbuild: true
|
|
sharp: true
|
|
unrs-resolver: true
|
|
vue-demi: false
|
|
patchedDependencies:
|
|
"@embedpdf/core@2.15.0": patches/@embedpdf__core@2.15.0.patch
|
|
"@embedpdf/engines@2.15.0": patches/@embedpdf__engines@2.15.0.patch
|
|
"@embedpdf/plugin-scroll@2.15.0": patches/@embedpdf__plugin-scroll@2.15.0.patch
|
|
minimumReleaseAgeExclude:
|
|
- "@tsconfig/node24@24.0.5"
|
|
- "@vue/language-core@3.3.10"
|
|
- concurrently@10.0.5
|
|
- jose@6.2.9
|
|
- vue-tsc@3.3.10
|